Frequently Asked Questions

What devices is the Conexum app compatible with?
Last Updated a year ago

The Conexum app can be downloaded to any smartphone or tablet that is running iOS 9.0 or above/ Android 5.0 or above (both with BLE 4.0 support).

Please Wait!

Please wait... it will take a second!